25. Mai 2012 · 6 Kommentare · Kategorien: Open-Source · Tags: ,

Irgendeinen Fehler hat der network-manager in Ubuntu 12.04. Zumindest unter GNOME und bei meinem Notebook lässt sich ein einmal deaktiviertes Netzwerk nicht mehr aktivieren. Da hilft auch kein Neustart mehr. Und in den Einstellungen ist eine Aktivierung irgendwie nicht mehr möglich. Der Regler regt sich einfach nicht (ja, auch wenn der Flugzeugmodus deaktiviert wurde).

Anzeige

Eine Inaktivierung der Drahtlosverbindung ist einfach

Aktivieren lässt sich das Netzwerk allerdings nicht mehr (auch wenn Flugzeugmodus vorher deaktiviert wird)

Ich weiß leider nicht, wo der Fehler liegt. Liegt es am Treiber, am network-manager, an mir? Jedenfalls habe ich nach einer kurzen Internet-Recherche herausgefunden, wie das Problem behoben werden kann. Man benötigt für die Fehlerbehebung das Tool rfkill, welches (soweit ich mich erinnern kann) in Ubuntu nicht standardmäßig installiert ist (kann mich aber auch täuschen).

Folgender Befehl führt dazu, dass alle Netzwerkadapter wieder aktiviert werden, also LAN, WLAN, Bluetooth, etc.

rfkill unblock all

Zumindest funktioniert es bei mir so. Allerdings finde ich das Ganze recht seltsam, sodass ich mir vorstellen könnte, dass es sich bei mir um Einzelfall handelt. Ich werde mich jetzt mal auf die Suche nach einem geeigneten Bugreport machen und den evtl. hier später noch dranhängen.

Anzeige


6 Kommentare

  1. Hallo, hatte das selbe Problem. Habe keine Ahnung gehabt, woran es liegen könnte und mal versucht den NetworkManager durch wicd zu ersetzen, was aber auch nicht half und irgendwie nach dem Zurückstellen gings dann wieder oder so, also sehr mysteriös…

  2. Scheint wohl ein wirklich heftiger Bug zu sein.

  3. Ich hatte diesen Bug auch mit Ubuntu 11.10 wobei ich auch eine Zeit lang Fedora benutzt haben und dort war glaub auch der Bug . Im mom nutze ich Ubuntu 12.04 + Unity daher kann ich nicht sagen wie es jetzt mit dem Bug aussieht 😀
    Solch ein offensichtlicher Bug würde aber wohl auffallen ist wohl Hardware/Treiber bedingt , wodurch wohl nur wenige Leute betroffen sind ? (meine Theorie ^^) . Gibt es im Launchpad eigentlich ein Bug-Report ? habe auf die schnelle zumindest keine gefunden …

  4. Wenn ich die Verbindung zu meinem W-Lan verliere, lässt sie sich nur in seltensten Fällen wieder herstellen. Meist muss ich neustarten. Irgendwas passt da im networkmanager auf jeden Fall noch nicht.

  5. Florian Bäuerle

    Ich hatte so ein ähnliches Problem schon mal mit einem Samsung Netbook (ein NC10, glaube ich). Installiert ist Archlinux, damit alle FN-Tasten Funktionieren gibt es die samsung-tools (https://launchpad.net/samsung-tools). Mit denen konnte ich zwar das WLAN deaktivieren, aber aktivieren war unmöglich.
    Habe den Spaß wieder runtergeworfen, seitdem funktioniert es bestens – Könnte evtl auch daran liegen wenn es ein Samsung ist.

  6. Vielen Dank für den Artikel. Habe das gleiche Problem unter Oneiric. Da ist rfkill übrigens schon in der Installation drin gewesen.

    Beste Grüße,
    Johnny

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.