23. Juni 2011 · 3 Kommentare · Kategorien: Open-Source · Tags: ,

Bereits seit Wochen (wenn nicht Monaten) hab ich in meinem Ubuntu-System Probleme mit dem Rendering der Schrift im Browser. Eingesetzt wird derzeit Ubuntu 10.10, als Browser läuft Chromium. Ich hab inzwischen mehrere Dinge ausprobiert, zum Erfolg hat keine der Möglichkeiten funktioniert. Heute hab ich das Problem – à la Windows – behoben.

Nein, ich hab nicht mein komplettes System aufgesetzt, das wär mir die Sache auch wieder nicht wert gewesen. Trotzdem hab ich mich an den hässlichen Schriftarten gestört, die mir der Browser bereits seit Wochen auf den Bildschirm gezaubert hat. Das Hauptproblem war, dass ich nicht genau wusste, woher das Problem kam. Auch eine Löschung des chromium-Ordneres in ~/.config brachte nicht die ersehnte Besserung

Die Glättung der Schriften von normalen Desktop-Programmen funktionierte wie eh und je, an den GNOME-Einstellungen lag es nicht. Die sahen und sehen so aus:

Einstellungen Schriftwiedergabe

Die Schriften im Browser waren dagegen grässlich. Hier mal ein Screenshot, damit ihr versteht, was ich meine.

Font Rendering schlecht

Bemerkbar war das Problem vor allem dann, wenn die Schriftart zu klein war und ich zoomte. Dann wurden die Schriften entweder zu dick oder zu dünn und nicht einfach „größer“. Heute hab ich mich mal dazu entschieden auszuprobieren, ob ein neues Benutzerkonto Besserung verspricht – oder ob es wirklich am Programm selbst liegt.

Also, neues Konto angelegt, schnell eingerichtet und siehe da. Ein Unterschied wie Tag und Nacht:

Font Rendering gut

Der Unterschied ist wirklich gravierend. In dem Moment frag ich mich gerade, warum ich es überhaupt so lange mit der verkorksten Schriftkantenglättung ausgehalten habe. Naja, man gewöhnt sich an alles.

Woran das Problem jetzt wirklich liegt, weiß ich nicht. An den Einstellungen – nein, am Browserprofil – nein. Wo dann? Ich hab keine Ahung. Auf jeden Fall funktioniert es im sauberen Benutzerprofil inzwischen wieder.

Update: Hab jetzt das Problem doch noch entdeckt. Es reicht, die Datei .fonts im home-Verzeichnis zu löschen. Hätte ich auch früher draufkommen können.

Anzeige


3 Kommentare

  1. Also der erste Screenshot sieht ja echt übel aus. Mir würde da schlecht werden müsste ich mehr solcher Texte lesen.

  2. Ah, hast du das Problem jetzt lösen können 🙂 Wir hatten ja neulich mal drüber gesprochen.

  3. Oh ja. Ich hab mich ewig damit rumgeärgert, dabei war die Problembehebung eigentlich sehr einfach. Aber manchmal hat man einfach Tomaten auf den Augen :-).

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.